[xmlsec] xmlsec failing validation tests

dheitmueller dheitmueller@netilla.com
Fri May 24 21:15:12 PDT 2002

No luck.  I uninstalled the original libxml (v1) rpm that was on the system, and it produced the same result.

I pulled down the Mandrake version of libxml2 1.0.17 RPM, as well as compiled it from xmlsoft.org, with the same result.

I downloaded and compiled the latest CVS snapshot of OpenSSL 0.9.7 with still no luck.

Can I get the xmlsec binary to dynamic link the libxml2 and libxslt libraries?  Then perhaps I could track down where it is pulling libraries from.

Any additional thoughts?

On a separate note, this experience is prompting me to consider breaking xmlsec into three different RPMS, instead of just the one.  This way we would have a source RPM for those who want to modify xmlsec itself, a xmlsec-devel RPM for those who want to develop solutions that use xmlsec, and a xmlsec binary RPM that is to be used for production systems.  It would also eliminate the dependency on libxml2-devel and libxslt-devel for production environments that don't have the toolchain installed.

Thanks for all your help,


Quoting Aleksey Sanin <aleksey@aleksey.com>:

> Looks like there is a problem on LibXML level. One of possible reasons
> is
> library mismatch (xmlsec loads old/wrong version of LibXML2 libraries
> when you are compiling it). I would suggest to do following:
>     1) ungzip/untar xmlsec-*.tar.gz into new folder
>     2) run the following commands and note the installation prefixes for
> both
>     packages:
>         rpm -ql libxml2-devel
>         rpm -ql libxslt-devel
>    3) ./configure --with-libxml=<libxml2-instl-prefix> 
>  --with-libxslt=<libxslt-instl-prefix>
>         make
>         make check
> Also I would strongly recommend to switch to OpenSSL 0.9.7. The 0.9.6 
> support
> will be dropped as soon as 0.9.7 will be officially released (probably 
> next month).
> Aleksey.
> dheitmueller wrote:
> >I have installed the xmlsec-0.0.5 source tree on my Mandrake 8.1
> system.   It appears to compile fine, but it fails all the tests in the
> test suite with errors such as the following:
> >
> >validity warning: or: Error: failed to read XML file
> "./merlin-xmldsig-twenty-three/signature-enveloped-dsa.xml"
> >
> >I added some debug code, and found that the call to
> xmlCreateFileParserCtxt() in the xmlSecParseFile() in xmltree.c fails.
> >
> >I installed the xmlsec binary RPM, which appears to work fine.  It
> passes the tests found in the source tree.
> >
> >I had to install the following RPMS to get the xmlsec library
> installed:
> >
> >libopenssl0-devel-0.9.6c-2mdk
> >openssl-0.9.6b-1mdk
> >libopenssl0-0.9.6c-2mdk
> >libxml2-2.4.21-1mdk
> >libxml2-devel-2.4.21-1mdk
> >libxslt-devel-1.0.17-2
> >libxslt-1.0.17-2
> >
> >Has anyone seen this behavior before?  Any idea why the binary version
> of xmlsec 0.0.5 would work, but the version compiled from source would
> fail?
> >
> >Thanks in advance,
> >
> >Devin Heitmueller
> >Senior Software Engineer
> >Netilla Networks Inc
> >
> >_______________________________________________
> >xmlsec mailing list
> >xmlsec@aleksey.com
> >http://www.aleksey.com/mailman/listinfo/xmlsec
> >

Devin Heitmueller
Senior Software Engineer
Netilla Networks Inc.

More information about the xmlsec mailing list