[xmlsec] Unable to dynamically load crypto lib

Ani A aniruddha.a at gmail.com
Thu Oct 8 22:50:48 PDT 2015


I am using xmlsec with Lasso [1], I compiled both, from source [2].
When I tried running an example
program, I got the following error:

  $ ./main ./key.pem ./cert.pem
function failed:filename=libxmlsec1-openssl
library function failed:crypto=openssl
library function failed:

  (process:31116): Lasso-CRITICAL **: 2015-10-08 18:09:32
(lasso.c/:182) Unable to load default xmlsec-crypto library. Make sure
  that you have it installed and check shared libraries
path(LD_LIBRARY_PATH) environment variable.

xmlsec seems to be using openssl as the crypto lib, and I have openssl

  ani at bld:sp-cgi$ pkg-config --modversion openssl

I also tried:

   $ export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/

Didnt help!

Does this have to do with any missing flag to `configure` script ? or
I am missing some other
dependency here?

[1] http://lasso.entrouvert.org/
[2] I am on Ubuntu 12.04 server - and somehow I was unable to install
xmlsec via apt-get


More information about the xmlsec mailing list