[xmlsec] Problem with multiple X509Certificates

Flávio Costa fcosta75 at gmail.com
Wed Nov 17 12:01:12 PST 2010


I developed my Delphi application using DLLs downloaded from
ftp://ftp.zlatkovic.com/libxml/ and everything was fine on my tests using my
company A1 certificate.

When deploying to my first customer, his signed XML contained 4 distinct
X509Certificate tags. After inspecting my code, I found that this strange
error was created by libxmlsec, and some google search lead me to version
1.2.16, which contains a fix for this problem. But zlatkovic only provides
binaries for version 1.2.13, so I tried to compile myself.

The following was compiled successfully with MS Visual Studio 2010:

Using new compiled DLLs, my Delphi code reached the following assert on
list.c line 184:

xmlSecAssert2(dst->id == src->id, -1);

I've tried to compile libxmlsec version 1.2.13 again, but my code only works
with zlatkovic's binaries. Every version (1.2.13, 1.2.14, 1.2.15) has this
same assertion.

Any suggestions?

Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.aleksey.com/pipermail/xmlsec/attachments/20101117/bbaab624/attachment.html>

More information about the xmlsec mailing list