[xmlsec] Build error with 1.2.16

Frank Büttner Frank.Buettner at webinstore.de
Tue Oct 5 23:41:16 PDT 2010

I have found it,
the problem was, that I have uses my own version of libxml2 and the
system version of libxslt from CentOS5. And  when I look at the 
include paths at the compiling line , I seen the the headers of
libxml2 are first included from CentOS and then my own.
And this was it. After build my own version of libxslt which
use my libxslt all was ok. So the xmlsec lib was totally guiltless.

Thanks, for help.

Betreff: Re: [xmlsec] Build error with 1.2.16

Hm... This is weird. The XML_C14N_1_1 and other constants are defined
in LibXML2's include/libxml/c14n.h file. Can you attach the complete
config.log and the complete output of make command?


On 10/5/10 1:22 AM, Frank Büttner wrote:
> Hello, when I try to build xmlsec,
> I get the follow error:
> c14n.c: In function 'xmlSecTransformC14NExecute':
> c14n.c:423: error: 'XML_C14N_1_0' undeclared (first use in this function)
> c14n.c:423: error: (Each undeclared identifier is reported only once
> c14n.c:423: error: for each function it appears in.)
> c14n.c:431: error: 'XML_C14N_1_1' undeclared (first use in this function)
> c14n.c:439: error: 'XML_C14N_EXCLUSIVE_1_0' undeclared (first use in this function)
> I have try libxml2-2.7.4 and 2.7.7 always the same result.
> What do I wrong?
> _______________________________________________
> xmlsec mailing list
> xmlsec at aleksey.com
> http://www.aleksey.com/mailman/listinfo/xmlsec

More information about the xmlsec mailing list