[xmlsec] Error: failed to initialize keys manager

Aleksey Sanin aleksey at aleksey.com
Wed Mar 19 08:02:29 PST 2008

Sounds like there are some "bad" files in the directory
that openssl uses for storing certificates. Check openssl
man page for exact location.


Web Master wrote:
> I am trying to install xmlsec to use with the Google Apps SSO PHP 
> sample. Everything installed properly but when I run the demo I get the 
> following error. I get the same error when run from the command line. 
> I've read that there may be something wrong with the default 
> certificates directory, but I do not know what that means. Any ideas or 
> a new direction to try would be appreciated. I'm out of options.
> func=xmlSecOpenSSLX509StoreInitialize:file=x509vfy.c:line=651:obj=x509-store:subj=X509_LOOKUP_add_dir:error=4:crypto 
> library function failed:
> func=xmlSecKeyDataStoreCreate:file=keysdata.c:line=1328:obj=x509-store:subj=id->initialize:error=1:xmlsec 
> library function failed:
> func=xmlSecOpenSSLKeysMngrInit:file=crypto.c:line=313:obj=unknown:subj=xmlSecKeyDataStoreCreate:error=1:xmlsec 
> library function failed:xmlSecOpenSSLX509StoreId
> func=xmlSecOpenSSLAppDefaultKeysMngrInit:file=app.c:line=1270:obj=unknown:subj=xmlSecOpenSSLKeysMngrInit:error=1:xmlsec 
> library function failed:
> Error: failed to initialize keys manager.
> Error: keys manager creation failed
> _______________________________________________
> xmlsec mailing list
> xmlsec at aleksey.com
> http://www.aleksey.com/mailman/listinfo/xmlsec

More information about the xmlsec mailing list