[xmlsec] XML Encryption

Mike Fudd mifudd at hotmail.com
Wed Jan 3 07:28:35 PST 2007

Hello Aleksey,

I must bother you again with my problems.
If I run testEnc.sh in a Cygwin environment I get this error messages:
>check-transforms: command not found
>encrypt-tmpl: command not found
Maybe some scripts are missing.

In your last eMail you answered that the template has nothing to do with the 
file to encrypt. So the template file "encrypt1-tmpl.xml" should work for my 
example. But if I try it I get the message "Error: failed to encrypt file 
with template "encrypt1-tmpl.xml""

This is the command I have tried:
--xml-data Example.xml
--session-key des-192
--node-name Passwords
--output result.xml

The error message is:
>Error: failed to encrypt xml file "Example.xml"
>Error: failed to encrypt file with template "encrypt1-tmpl.xml"

If I look in xmlenc.c the error occurs in section "/* push data thru */". It 
seems that the node and their childnodes were not found, because in this 
section were this data encrypted. But the node is correct, because if take a 
node name that is not in Example.xml the message is "node not found." -> 
Must the node I want to encrypt have a special assembly?



FREE pop-up blocking with the new MSN Toolbar - get it now! 

More information about the xmlsec mailing list