[xmlsec] Xmlsec not ok with AIX 5.2

ASSO asso at cp.finances.gouv.fr
Thu Jan 5 10:44:17 PST 2006

I tried with many different ways to compile xmlsec for AIX 5.2
using GCC 3.3.2 and I am not able to get it working with OpenSSL 0.9.7 or 0.9.8.
I tried (among other tries) :
- compile it using openssl 0.9.7 precompiled by IBM (both shared and static)
- using openssl 0.9.8 compiled from source with gcc (no shared only static since the
configure refuse to make a shared version)
- compiled with shared xor static option
- using special option --enable-crypto-dl=no and --enable-apps-crypto-dl=no or not

Whatever I tried, it is broken :
- when using 0.9.7 : error during compile on x509vfy.c line 594 structure has no member
named 'depth'
- when using nothing static (crypto-dl not specified), it compiles ok but check goes only
    I looked at the log and the reason is it cannot load the libraries xmlsec-openssl.so.
    Note that it only compiles libxmlsec[-openssl].a and not '.so' , which I suppose is
correct on AIX.
    Of course, PATH, LIBPATH, LD_LIBRARY_PATH have in first place the right place
    for the libraries or binaries.
    During the compile, it shows a warning :
    Warning: Linking the shared library libxmlsec1-openssl.la against the static library
.../lib/libcrypto.a is not portable!

- when using static, it does not compiled and complain about not COFF libraries
    Or it just core dumped when running the check if it goes until the end of
compile.(crypto-dl not set).

Note that I was able to compile openssl, libxml and libxslt with no problem
and the test (check or equivalent) are all ok.

Any Ideas ?


More information about the xmlsec mailing list