[xmlsec] Missing namespace in keyinfo from xmlSecTmplSignatureEnsureKeyInfo ?

Aleksey Sanin aleksey at aleksey.com
Tue Jul 12 08:37:13 PDT 2005

> When i run sign1, i got the following result :
> Error: no namespace for keyInfo !!:
> Error: Still no namespace for keyInfo !!:
> <?xml version="1.0" encoding="UTF-8"?>
> <!--
> XML Security Library example: Simple signature template file for sign1 example.
> -->
> ....
> ....   
> <SignatureValue>JJ/qZpTE+Tx9Yq1qYhPvYN9jFhGdQstDTZ7BPa2D5xSgxH8+Yx2JxGBL5iL/9Ycf
> VM9meZrHt6MyHv/cEUnDOkO6qBW5+r0jXQJSN7dkABrnQRdepAKHsAFx+lXE96lJ
> cu5chSQ3Kiv+IArUuPKSLo8YUckQG89IbyIPSJgYiII=</SignatureValue>
> <KeyInfo>
> <X509Data/>
> </KeyInfo>
>   </Signature>
> </Envelope>
> So i see that :
> my keyinfo tag as been added to the xml, but without any namespace :-(
Can you attach the *whole* document, please? Namespace might be
declared in the parent and I would guess that in this case it
was declared in the Signature node.

> If the namespace is not set, validation of my document with xml schema won't
> work. Of course, i could set it manually, but i sure i missed something,
> because namespace is set in all the othe tag, and what i see in the code let
> me think it should be set even for keyinfo...
Again, will you mind to attach the whole document, please?


More information about the xmlsec mailing list