[xmlsec] Certificate verification failure

nitin singh xml_prgrm at yahoo.com
Sat Dec 4 08:42:33 PST 2004

Hello Aleksey,
Yes, in openssl list, no body seems to have any idea. I did take some steps to see what is 
causing the error.
I ran 'make test' for openssl, it passed all the test. In xmlsec I did not run the 'make check'
but I did run the example verify3.c, where a signature has to be verified against a given 
X509 cert. As expected it failed, with the same errors :( ....
The only lead which I had was that may be I am not compiling openssl with right platform 
option. My options were...
./configure linux-elf-arm --prefix=/usr/local shared
but make test ran fine....
my gcc compiler is arm-gcc-3.2.3 was thinking for recompliing openssl with linux-arm-gnu (by manually changing the configure file) because this is the option I use to compile other libraries including xmlsec, and everything runs ok but signature verification fails.
Let me check this too, (just been busy with some other stuff.)
I will be grateful if you have any ideas on this.

Aleksey Sanin <aleksey at aleksey.com> wrote:
Hi, Nitin!

Any progress with this error? I have seen your question in openssl
mailing list but there were not replies.

BTW, have you tried to run xmlsec regression tests ('make check' from
the top level xmlsec folder) on arm platform? What are the results?


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.aleksey.com/pipermail/xmlsec/attachments/20041204/9cb9f36d/attachment-0002.htm

More information about the xmlsec mailing list