SV: [xmlsec] Canonicalization problem?

Johannes Kjos Johannes.Kjos at
Mon Sep 1 01:50:20 PDT 2003

Thanks! Using libxml2 2.5.10 (my former was 2.5.4) solved my problem! 


-----Opprinnelig melding-----
Fra: Aleksey Sanin [mailto:aleksey at]
Sendt: 29. august 2003 19:10
Til: 'xmlsec at'
Kopi: Johannes Kjos
Emne: Re: [xmlsec] Canonicalization problem?

My bad, I had a worng path settings thus I got this strange results.

Anyway, going back to original problem. I found that if I use libxml2 
2.5.4 or 2.5.5 (I've not tried others) then I get the same error as Johannes
reported with both xmlsec 1.1.x and 0.0.x. However, if I upgrade to libxml2
CVS trunk (and I would guess the same for the latest 2.5.10 version) then
everything works as expected for both xmlsec 1.1.x and 0.0.x.

Johannes, can you try to re-compile xmlsec with libxml2 version 2.5.10
(and may be CVS trunk). This have solved problem for me.


> Ok, I see it too and this is weird:

More information about the xmlsec mailing list