[xmlsec] Problem compiling on Mac OS X

Dan Timis timis at museresearch.com
Fri Jun 13 10:47:19 PDT 2003

I tried again making xmlsec with ./configure --with-openssl=/usr/local 
and this time it worked.

Now I have things all over the place so who knows why it worked this 
time.  I give up.  I have a build so I'll start using it.


On Wednesday, June 11, 2003, at 09:36 PM, Aleksey Sanin wrote:

> Good! We finally have similar results :) Unfortunately, this log is not
> very usefull because it does not show the error you had before.
> But assuming that '/usr/local' configuration is exactly the same as
> '$HOME' with replacement $HOME->/usr/local I see no problems
> with gcc and ldd command options.
> The only idea I have is that you do not have permissions to read
> openssl libraries from the /usr/local/lib (note that on Mac you need
> *both* read and execute permissions).  If it is not the case and
> everything is ok with permissions then you can have something
> in your enviroment but I have no idea what.
> Aleksey
> Dan Timis wrote:
>> On Wednesday, June 11, 2003, at 06:57 PM, Aleksey Sanin wrote:
>>> The last idea: I actually use "--prefix=$HOME" instead of 
>>> "--prefix=/usr/local".
>>> Can you try it? And it would be helpfull if you can post your xmlsec 
>>> build log.
>> It worked!  But, why?  Here is the entire log for xmlsec from 
>> configure to install.  I am not sending it to the list because it is 
>> very long.
>> Thanks,
>> Dan
> _______________________________________________
> xmlsec mailing list
> xmlsec at aleksey.com
> http://www.aleksey.com/mailman/listinfo/xmlsec

More information about the xmlsec mailing list