[xmlsec] Problem compiling on Mac OS X

Dan Timis timis at museresearch.com
Wed Jun 11 18:17:31 PDT 2003

On Tuesday, June 10, 2003, at 11:17 PM, Aleksey Sanin wrote:

> I would suggest to compile openssl with './config --prefix=/usr/local' 
> and
> later compile xmlsec with './configure --with-openssl=/usr/local'. If 
> I understand
> everything correctly it should solve the problem and you would not 
> need to move
> some shared libraries around.

That makes total sense.  However, it still doesn't work.  The manual 
for ld says:

>        -Ldir  Add  dir  to  the  list  of directories in which to
>               search for libraries.  Directories  specified  with
>               -L are searched before the standard directories.

The flags are -L/usr/local/lib -lcrypto.  So you would think that it 
will use /usr/local/lib/libcrypto.a and not /usr/lib/libcrypto.dylib.

What compiler version ate you using on the Mac?  What version of the 
OS?  I am using Mac OS 10.2.6 and gcc (GCC) 3.1 20020420 (prerelease).

I even built openssl with the "shared" option.  So I have also 
/usr/local/lib/libcrypto.dylib and it still doesn't work.

I can do one of the following:

1.  Move /usr/lib/libcrypto.dylib to /tmp and back
2.  Configure xmlsec without the openssl prefix, in which case it will 
use 0.9.6
3.  Configure openssl with prefix /usr/lib.

However, it would still be helpful to find out why it's working for 
you. but not for me.


Dan Timis

More information about the xmlsec mailing list