[xmlsec] xmlse usage

Aleksey Sanin aleksey at aleksey.com
Sun Dec 22 16:27:22 PST 2002

I am not sure I clear understand what does the "generation algorithm 
RSA-SHA1" mean
but assuming that server.key has a private RSA key then you should check 
that xml.txt
template uses RSA-SHA1 signature algorithm. This is the only reasons I 
can think of for
the error you have.

BTW, I think it'll be very helpful if you send related files next time :)


Wayne Cheng wrote:

>Thank you so much for your quick response.
>The server.key generation algorithm we used is RSA-sha1. I am not sure where to
>algorithm used for signature for xmlsec utility.
>I tried the new format and it still not working. Also, I am not sure if rename
>for server is required or not.
>bash-2.05$ xmlsec sign --privkey:server ./server.key xml.txt
>xmlSecKeysMngrGetKey (keys.c:451): error 17: key not found :
>xmlSecSignedInfoRead (xmldsig.c:1385): error 17: key not found :
>xmlSecSignatureRead (xmldsig.c:1124): error 2: xmlsec operation failed :
>ignedInfoRead - -1
>xmlSecDSigGenerate (xmldsig.c:792): error 2: xmlsec operation failed :
>natureRead - -1
>Error: xmlSecDSigGenerate() failed
>Error: operation failed

More information about the xmlsec mailing list