[xmlsec] problems with dsig2 and dsig3 examples

Devin Heitmueller dheitmueller at netilla.com
Thu Aug 29 10:28:46 PDT 2002

I am having problems getting the example code that comes with
xmlsec-0.0.9 working.

I have a Mandrake 8.2 system, and I have compiled libxml2-2.4.24 and
xslt-1.0.20 from source.  They have been installed in /usr/lib (by
modifying the --prefix in configure).

The dsig1 example appears to work fine.  However, when I run the dsig2
example, I get the following output:

[root at devin dsig2]# ./dsig2 dsakey.pem test.tmpl 
xmlSecTransformStateParseUri (transforms.c:1157): error 4: xml operation
failed : xmlXPtrEval(xpointer(id('SomeData'))) 
xmlSecTransformStateCreate (transforms.c:881): error 2: xmlsec operation
failed : xmlSecTransformStateParseUri(#xpointer(id('SomeData'))) 
xmlSecReferenceRead (xmldsig.c:1550): error 2: xmlsec operation failed :
xmlSecSignedInfoRead (xmldsig.c:1424): error 2: xmlsec operation failed
: xmlSecReferenceRead - -1 
xmlSecSignatureRead (xmldsig.c:1124): error 2: xmlsec operation failed :
xmlSecSignedInfoRead - -1 
xmlSecDSigGenerate (xmldsig.c:792): error 2: xmlsec operation failed :
xmlSecSignatureRead - -1 
Error: signature failed

I get the exact same error when I run "./dsig3 test.xml"

Any ideas?

On a sidenote, on line 34 of dsig2.c, argc should be 3, and on line 32
of dsig3.c, argc should be 2.  In both cases, the check is for one few
too arguments.


Devin Heitmueller
Senior Software Engineer
Netilla Networks Inc

More information about the xmlsec mailing list